DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
My RPM keeps going up and down about 100 RPM for no reason. It seems to do it a lot more with the cruise on. Also it only seems to do it at RPM's below 2,000. Does it weather in over drive or 3rd gear. My tranny fliuid is super clean, so clean that maybe it's been rebuilt recently. There is no slipping when taking off from a stop or at any other time that I can notice. My guess is the torque converter. Anyone else had this problem? I just bought the truck a couple months ago and didn't notice it doing this until a week ago. The truck has 145,000 miles on it. Also, my speedometer is off a bit. It reads about 5 MPH too slow at 50 MPH. I bought it from a dealer, so I don't know any history other than the carfax was clean. Maybe the speedo was recalibrated by a previous owner who may have had bigger tires on it? Other than this, I really like the truck.
 

·
Registered
Joined
·
6,008 Posts
I believe the truck had bigger tires on it. If the speedo is off then the guys before must of had bigger tires. I put bigger tires on my truck and my speedo was off, I used my programmer to adjust it.

For the RPMs i do not know what that could be. Check if the guy had a programmer in before, look for a foot print
 

·
Dodge Ram Forum - Dodge Truck Forum - Dodge Ram Cl
Joined
·
2,169 Posts
We had a similar problem with our 2000 Ram 1500. It had a strong smell of gas too during idle. After many mechanics ad lots of money, we found out that it was the speed control sensor and about a 35 dollar part.
 
1 - 3 of 3 Posts
Top