DODGE RAM FORUM banner

1 - 7 of 7 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
I get a "Service Tire Pressure System" warning light when I start my truck followed by the tpms light flashing about 10-15 times then goes solid.

I had a similar problem when I first bought my truck and it was under warranty. (After installing aftermarket wheels and transferring the sensors) Dealer couldn't figure it out and said they replaced my computer system because it wasnt communicating and gave me two new keys to the truck as everything had to be reprogrammed.

Fast forward 3 years, seems like the same issue is back. I read somewhere online about it possibly being a nail in the tire? I found a few.. but needed new tires regardless. I recently purchased new tires at discount tire, they reset the tpms sensors and warning message went away for about a week. Now it's been back on for a month consistently.

Anyone else with a similar issue? Any diy fixes? Last thing I want to do is drop thousands on this issue at the dealer and hundreds on new keys..? Any help would be much appreciated.
Thanks
 

·
Registered
Joined
·
12 Posts
I hope this may help..my truck did the same thing until I basically got the tire pressures between the pressure zones that didnt trigger the warning...so mine seems to b happy at 35psi
 

·
Registered
Joined
·
114 Posts
Tire Pressure

Glad you found a solution to the tire problem.

Some tire guys are conscientious when inflating tires. However, some tire guys just use an imaginary number, and perhaps some use the WAG system when inflating all tires, regardless of details, e.g., tire size, manufacturer specs. Taking 5 seconds to read the door jamb label is for tire "rookies."
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #6 ·
Well that lasted all of about 2 days... lights back on. I guess taking air out reset the system but didn't fix the issue.
Update: when I start the truck, no light for the first 5-10 seconds. Followed by a beep and then "service tire pressure system" + 60 flashes of the tpms light and then solid yellow. Anyone else experience this?
 

·
Registered
Joined
·
16 Posts
My 2010 said my drivers rear was at 29psi before I could inflate tire now the front drives side does not read at all.I recently had the battery replaced.if I disconnect the battery will it reset?
 
1 - 7 of 7 Posts
Top