DODGE RAM FORUM banner

1 - 13 of 13 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter #1
OK. so here is the problem. Do you grab the wool or what do you hold on to???

SO the real issue is that I got the a518 (46re) rebuilt oin my 1996 Dodgge ram 2wd with a 5.9. I am experiencing a shift issue, Last night I pulled a code of P0783 no 3-4 shift torque converter locks up in third I have to hold the pedal steady to get it to shift from 1-2-3. Or I can shift it manually.
Fluid is full, and clean, all sensors were working before removal (from what the trans guy said). The truck was neglected look at my "boobs" thread in the intro. All clutches were good except for the ones controlling 2nd gear before the rebuild. the inside has new steels and clutches as well.
 

·
Registered
Joined
·
2,037 Posts
If a stock transmission, you must check trans fluid with engine running, trans in neutral, preferably warmed up.
 

·
Registered
Joined
·
109 Posts
Discussion Starter #5
Check trans fluid with engine running in neutral and fully upto temp. Fluid is full all connecters hooked up and it is clean.
 

·
Registered
Joined
·
3,062 Posts
I've heard, in Scotland, the sheep farmers wear knee high boots, can't imagine why, though. Warmed up,in park, at idle, hind leg in each boot, dipstick inserted.:wow:
 

·
Registered
Joined
·
278 Posts
it may be an issue from the re build. when i went to my advanced course i rebuilt a 4l80e and if everything isnt within the precise measurements taken with a micrometer then something will fail. also some transmissions have little metal balls that sit over holes in channels fluid pushes them up with the correct amount of pressure and sends them down the channels to engage different clutch packs. if one of those is missing then you are always flowing fluid to that channel and that clutch pack. so you are trying to engage 2 gears at ones...obviously this doesnt work
 

·
Registered
Joined
·
109 Posts
Discussion Starter #9
I know the valve body is sealed unless you pull it apart but I kept it as a whole unit. Everything is with in specs as well all measurements for what the factory calls for.
 

·
Registered
Joined
·
278 Posts
the only thing left i can think of is the shift solenoids or the torque converter itself ( i highly doubt the tc but never know)
 

·
Registered
Joined
·
2,037 Posts
I heard they shag 'em facing a cliff so they'll push back. Anyway, yeah, it sounds like an issue in the valve body. For some reason I'm thinking maybe the line pressure is too low.
 

·
Registered
Joined
·
109 Posts
Discussion Starter #12
Yea I am thinking shift solenoid I did the horn relay swap and ruled out the relay. If it was line pressure I shouldn't be getting a 1,2,3 shift the delay could be fault internals in the valve body damaged spring or stuck (varnished) check balls. As for the torque converter it locks up at about 1700-2100rpms in third gear which should be normal. I can live without overdrive just nice to know I went from 100miles on a half of a tank to 100 miles on 1/4. So probably will replace the valve body, and the TV cable as well.
 

·
Registered
Joined
·
14 Posts
Not all sheep have wool, so you can't count on grabbing the wool.
Wearing a kilt is the best practice, that way they don't hear the zipper. :doh:

My two Scottish Soay rams.
 
1 - 13 of 13 Posts
Top