DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
581 Posts
Discussion Starter · #1 ·
Hey Guys, I got my PW a few weeks ago. Still love it, but I have a question. It hasn't been really cold here in Cincy (stupid weather), but I've noticed when I first drive my truck after it has sat for a while, like when I am at work or over night, it shifts really hard from 1st to 2nd. When I turn off the ESC it helps some. It just seems really strange. My 2010 1500 didn't do it. Is it becuase it is a solid axle? I looked under the truck but didn't see anything odd. Its almost like something klunks into place. It isn't something I want out of my new truck. I want to get some feed back about it before I go to the dealer. I don't want to screw anything up on it yet.
 

·
Registered
Joined
·
581 Posts
Discussion Starter · #2 ·
Anyone have any ideas? The dealer I got the truck from is an hour away. I don't want to make a day of it for nothing. Please help. Input needed.
 

·
Registered
Joined
·
360 Posts
This may not be the answer, but even though its not too cold out, when you first set off your vehicle wants to warm up very quickly for emissions the cats work best when hot. So it might just be shifting later at higher RPMs to try and warm up the engine. A trip to the dealer may be needed if the problem persists, better be safe than sorry.
 

·
Registered
Joined
·
581 Posts
Discussion Starter · #4 ·
Cool, thanks. Hadn't thought of that. It's weird, once I have gone up to about 3rd once or twice, it stops. Its like it isn't upshifting and when I take my foot of the gas, it does so kinda rough.
Thanks for the help!
 
1 - 4 of 4 Posts
Top