DODGE RAM FORUM banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
OK so long story short I have a 2016 ram 1500, 8-speed trans /5.7, with about 54,500 miles. Owned the truck now for about a year and a half and it started making up to 3 to 4 additional clicking noises early this year from what appeared to be the rotary shifter assembly. I got the update completed on the assembly…..and it did not solve the problem. I also had the entire rotary shifter assembly replaced….and it still had the additional clicking noises. After it is all said and done with some deep investigating of this issue, It turns out that for me, it was coming from the ignition system itself. Trucks ignition was replaced and since my truck is still under warranty, it was covered. That fixed the issue and it clicks one time now as it should. I hope this helps others who are experiencing this problem or at least gives you an idea of what to investigate.

-cheers
 

·
Registered
19 RAM 1500 5.7 Etorque. Falcon Wildpeak AT3W/ JMS PedalMax/weatherTech TechLiner/Gator Quad fold
Joined
·
1,197 Posts
OK so long story short I have a 2016 ram 1500, 8-speed trans /5.7, with about 54,500 miles. Owned the truck now for about a year and a half and it started making up to 3 to 4 additional clicking noises early this year from what appeared to be the rotary shifter assembly. I got the update completed on the assembly…..and it did not solve the problem. I also had the entire rotary shifter assembly replaced….and it still had the additional clicking noises. After it is all said and done with some deep investigating of this issue, It turns out that for me, it was coming from the ignition system itself. Trucks ignition was replaced and since my truck is still under warranty, it was covered. That fixed the issue and it clicks one time now as it should. I hope this helps others who are experiencing this problem or at least gives you an idea of what to investigate.

-cheers
Thanks for letting us know!
 

·
Registered
Joined
·
14 Posts
OK so long story short I have a 2016 ram 1500, 8-speed trans /5.7, with about 54,500 miles. Owned the truck now for about a year and a half and it started making up to 3 to 4 additional clicking noises early this year from what appeared to be the rotary shifter assembly. I got the update completed on the assembly…..and it did not solve the problem. I also had the entire rotary shifter assembly replaced….and it still had the additional clicking noises. After it is all said and done with some deep investigating of this issue, It turns out that for me, it was coming from the ignition system itself. Trucks ignition was replaced and since my truck is still under warranty, it was covered. That fixed the issue and it clicks one time now as it should. I hope this helps others who are experiencing this problem or at least gives you an idea of what to investigate.

-cheers
My 2016 ram started doing this same thing.it clicks 4 times when I go from park to drive or reverse. I assumed it was from the shifter because the clicking noise sounds like the noise im use to hearing when it does it once. After reading your post I listened closer and it sounds like it’s coming more from the ignition area.
How long was yours making this noise before you had it fixed?

the dealer can’t get me in for 2-3 weeks so I’m afraid of something going wrong and I won’t be able to drive it.
 
1 - 3 of 3 Posts
Top