DODGE RAM FORUM banner

1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I have a 2003 Ram 5.9L Magnum. One day I went to my local gym to go workout and it drove perfect on the way there. When I got back in after my workout to come home I turned the key and before even starting the truck the speedometer began acting up jumping everywhere randomly. 30 seconds after starting the truck I got a check engine light, abs light, and parking brake light come on at the same time. The code I'm getting is "P0720 – Output Speed Sensor Circuit Malfunction". The speedometer works perfect as soon as I get moving, but as soon as I stop it will start jumping again. I also noticed the transmission shifts funny when taking off, almost feels like its trying to take off in 4th gear and then finally shifts to 1st. It shifts fine while moving.


I replaced the speed sensor on the side of the transmission, but the problem did not go away. :doh:

Example While Parked:

http://www.youtube.com/watch?v=kr7TWN36548&feature=c4-overview&list=UUGQ-yCV7R2NcFqlCH7gHLzQ
 

·
Premium Member
Joined
·
32,659 Posts
I believe your transmission is ready to go into LIMP MODE, with your year that could be 3rd or 4th, i forget which
i wouldn't guess at the cause for the speedometer acting up

P0720 Dodge Description

The speed sensor detects the revolution of the idler gear parking pawl lock gear and emits a pulse signal. The pulse signal is sent to the Transmission Control Module (TCM) which converts it into vehicle speed.

Read more: http://engine-codes.com/p0720_dodge.html#ixzz2oFKRlEKc
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
Like I said the tranny shifts perfectly when moving, its only acting screwy when taking off from a dead stop. It has to be directly related to the speedometer issue, because it happened at the exact same time. I'm guessing when I'm at a stop and the speedometer is jumping around the transmission thinks I'm moving and not stopped so it shifts into an appropriate gear for such speed. If the speedometer issue is fixed I believe all that would go away. Do you think I need to look into replacing the speed sensor in the rear axle?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
Replaced the rear differential speed sensor today and then I turned the truck on, speedometer is still bouncing like crazy up and down. Any ideas? Anyone?
 
1 - 5 of 5 Posts
Top