DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hey everyone, I know this is a common issue with dodges in general but I didn't see a recent thread on the issue so here goes:
My 2010 ram with the 5.7 has a squeal/whine/chirp noise coming from the front of the engine in the belt area. It only seems to start when the engine is warmed up (15 minutes or more), and only does it occasionally, mainly at idle and dies when I start to get on the gas. There is one thing that mine has been doing that no one else complaining of these noises has mentioned. Sometimes when I shut the engine off and am walking away I will hear that same whine pitched noise blowing off as if its pressure relieving from something. I will try to get a video and post a link to it on youtube or something if I can catch it happening. I don't think its the belt or camshaft sensor or pulley like most people determine to be the issue, unless its a new gatorback belt with pressure relief option:LOL:.The only thing I can think of making a blow off noise is a pump.

Anyone have the same issue or at least some ideas?

I'm supposed to be driving from my base in Panama City, FL to my new base in Anchorage, Alaska in a month so I kind of need to figure this issue out lol. Thanks!
 

·
Resident Technician
Joined
·
14,202 Posts
An easy way to isolate belt noise is to spray the belt with water, silicone or belt dressing while the engine running and see if the noise changes or is eliminated. As for the 'blowing off" noise, I would suspect a weak radiator cap at first. If that's not it, I would look into a potential air conditioning problem.
 
1 - 3 of 3 Posts
Top