DODGE RAM FORUM banner

1 - 14 of 14 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
Hello, my 94 v8 5.2l 4x4 is stalling at highway speeds and has a low hard idle.

I cleaned the throttle body and replaced the MAP, TPS, and IAC. so now at speeds below 60mph the truck runs fine, but at idle the truck still idles hard and low. Also sometimes the oil light flickers with the idle, it used to show a drop in oil pressure at idle but with the new sensors it doesn't do it anymore.

going up hill doesn't have a significant effect on power loss, but speed does drop

If i remain at a constant speed above 60mph the truck will feel like it will stall but i wiggle the gas pedal and it goes back to normal for a few miles, or if i floor it has power and goes back to normal for a few miles. Doesn't show a oil pressure drop and oil light is not on.

Check engine light code shows a low air/fuel ratio

I think it might be the fuel or oil pump or a clogged fuel filter, what do you guys think?
 

·
Banned
Joined
·
7,866 Posts
Low idle can be caused by a faulty IAC or a bad 02 sensor.

With your symptoms I'd spend the $45 on an IAC and call it preventative maintenance.

The stalling sounds like a bad cat as does the power loss.
 

·
Banned
Joined
·
7,866 Posts
Since your's is a '94 I'd be inclined to lean towards the 02 sensor. Since there's only one (upstream) You can replace it for under 100 dollars.

I'm not a fan of throwing money at a vehicle so I'd try tapping on the cat with a dead-blow hammer and see if it rattles/tone increases/white residue comes out of the exhaust.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
my truck runs straight pipe stacks, there is not catalytic converter, and the o2 sensors were replaced before my last echeck about 5 months ago. when i get a echeck i put the original exhaust back on.
 

·
Registered
Joined
·
939 Posts
Since you have a 94, you may have the schrader-valve on the fuel line. Check for low fuel pressure before throwing any more parts at it. Normal is 45-55. But it will start and run as low a 25, but like shit.
 

·
Banned
Joined
·
7,866 Posts
Since you have a 94, you may have the schrader-valve on the fuel line. Check for low fuel pressure before throwing any more parts at it. Normal is 45-55. But it will start and run as low a 25, but like shit.

The story seems to be emerging as we go on. I agree with LT at this point.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
a buddy of mine had a extra new fuel pump and gave it to me, now the truck can go down the interstate a whole lot better, but when you stop the truck it idles below 500 and loses oil pressure. it still has the error code 51 (low fuel air ratio sensed by O2 sensor).

I also checked to see if maybe one of the new sensors were bad:
unplugging MAP sensor causes truck to die instantly
unplugging TPS causes the truck to idle sporadically
unplugging IAC changes nothing

I didn't pay anything for the pump so it was worth a shot.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
I think I found the problem

I was inspecting the exhaust line and before the first bend there is a hole, so i think the O2 sensor isn't getting enough exhaust and isn't telling the computer the correct ratios.
 

·
Registered
Joined
·
939 Posts
I hope we helped. Sounds like you are on the right path! An air leak in the exhaust before the O2 would skew the readings. Good luck Comrade.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
Solved!!!!!

So I patched the hole in my exhaust and my truck is back to 100%, i didnt know a quarter sized hole could cause so many problems......

Thanks everyone for your help!:smiley_thumbs_up::smiley_thumbs_up:
 

·
Registered
Joined
·
939 Posts
Alot of good people here that like to help. Thanks for the feedback that the issue is solved. Alot of posters don't give feedback. When someone posts it is solved, it adds to the knowledge-base for all of us. Thank you Comrade.
 
1 - 14 of 14 Posts
Top