DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just bought 88 ram d100 v6 3.9 I think. Had some issues am changing timing chain .bought new and it came with a tensioner guide. Pulled water pump .no tensioner on motor did I get the wrong part or am I missing something.did they add it later I saw some Dakotas had them but saw both kits for the 3.9
 

·
Registered
Joined
·
1,900 Posts
Could be a universal type kit and the tensioner is not used. You can count the links in the chains to see if it is the right chain. Or go back to the parts store and have them verify it is the right one.
 

·
Registered
Joined
·
2,006 Posts
The tensioner was added in the 1990's to the Magnum line, and was offered as an upgrade for all LA and Magnum engines. It's considered an upgrade when using stock type timing chains. I usually go a different route with an aftermarket double roller unit that'd eat that tensioner in a few minutes. The stock chains are fine for normal use, and are made to be friendly with the tension tabs on the tensioner. Magnums were routinely running over 200K miles with the stock setup. It works well. Some good pics here of one installed: https://www.forabodiesonly.com/mopar/threads/photo-of-an-installed-timing-chain-tensioner.402061/
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Well fixed the dodge, replaced timing without tensioner. Still eratic behavior, ended up being the wrong rotor button ,the previous owner couldn't get it to run ,no wonder, had 318 button installed and had lots of slack in it. Got new and parts store tried to sell me the same button. So beware ,runs like a champ now
 
1 - 4 of 4 Posts
Top