DODGE RAM FORUM banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I've been an avid Dodge owner for way too many years and have Unfortunately had to learn to do a lot of my own diagnosis and repairs. But this one has me stumped. My 11 Ram is Factory Stock, No mods. I have EVIC controls/cursers and radio controls on my steering wheel. All in one day, my EVIC controls & radio controls stopped working ALONG with my Power Inverter Outlet, reg. power outlets, Horns & Map lights.

I had gotten a low tire warning, stopped to air it up and then was going to put my EVIC back on Fuel Economy (because I'm anal about that) and my cursers didn't work. I turned the truck off then started back up, nothing changed. As the day went on I started to notice the other things that had stopped working. So far the things I listed are the only things I've noticed not working. I checked fuses then called Dealership and was told that it sounds like a relay. I swapped relays around and nothing changed at all. If I had a bad one, something else would have stopped working. It didn't. Anyone have a clue to what I can check before I take it in and get charged my first born grandson for fuse changing?
 

·
Registered
Joined
·
1,375 Posts
One quick thing to try that may work would be to disconnect the battery for about 20 minutes. This basically resets some memory on the computer. Also check the fuses and make sure they are seated properly. Pulling them in out and then pushing them in may clean up any oxidation on the fuse leads which could cause problems.

If it doesn't work you will probably have to take it in for service, it could be a bad module.
 
1 - 2 of 2 Posts
Top