DODGE RAM FORUM banner

1 - 14 of 14 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Id like to start out by asking all to forget that last post. Bottomline mechanic screwed me. I fixed his problem. After almost 1000. Anyway i needed to replace both my injectors and my regulator in addition to a few other things. Before one injector would be working while the other didnt work. But gas was pouring out of my relief hole. The truck would start and idle terribe. So i replaced my injectors and my regulator. Now im getting too much fuel.my engine floods so fast after the first crank it dies after a second. I had my gf turn the key while i looked at my injectors and they were both shooting like fire hoses. I read some where that it could be the MAP sensor? I thought maybe someone has had this problem before?
 

·
Registered
Joined
·
2,037 Posts
Did you reset the computer? If not, do that first. Yes, could be MAP. Could also be an internal vacuum leak in the throttle body. It's a simple rebuild with a $25 kit.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
I replaced the computer just before i did all this. How do you reset the cpu? Iv tried to get codes but i guess my light is actually out. How do you repair the throttle body?
 

·
Registered
Joined
·
2,037 Posts
No codes at all? Yeah, bulb is out or bad computer. Reset by unplugging the battery for a few minutes. Take ten, then come back and hook it up. Rebuilding the TB is easier than a carb. Just a couple bolts, two gaskets. Not much there, but vital. If there's a leak, it'll throw the whole thing into chaos. I recently went through this with mine. 23 years. I'd say it was due.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
No codes at all? Yeah, bulb is out or bad computer. Reset by unplugging the battery for a few minutes. Take ten, then come back and hook it up. Rebuilding the TB is easier than a carb. Just a couple bolts, two gaskets. Not much there, but vital. If there's a leak, it'll throw the whole thing into chaos. I recently went through this with mine. 23 years. I'd say it was due.
I think i might have a gasket set lying around here someplace. Are you talking about pulling the throttle apart into the two pieces and replacing the two gaskets there? Because my kit came with like six gaskets.

You wouldnt happen to know how to change the bulb for the engine light would you? Lol

And the map sensor is that sensor that the hose connects to, right above the tps?
 

·
Registered
Joined
·
2,037 Posts
Correct on MAP sensor location. Also, be aware that the MAP sensor hose will likely be getting brittle, could already have a leak. Just be easy. I had one that was still flexible at the MAP sensor, thought it was fine only to see it'd disintegrated on the other end from relatively minor movement.
The TBI kits typically cover the two sizes of TBI, as well as minor differences between Gen 1 and Gen 2 (for lack of a better term) TBI. Yes, take the TBI apart, replace the internal gasket, blow out the passages (especially the big vacuum port on the lower rear part of the body. The small rectangular "vacuum manifold" on the lower front of the TB must also be replaced. Mine appeared OK, but it was leaking somewhere because once re-done it ran beautifully. Before the repair it'd gotten so bad it literally sounded like an old 4 cylinder diesel tractor. A leak in those gaskets will throw the MAP outta whack too.
Haven't done a dash light repair, but it comes down to getting the proper bulb and pulling the dash panel out (oh joy).
 

·
Registered
Joined
·
28 Posts
Discussion Starter #8
Correct on MAP sensor location. Also, be aware that the MAP sensor hose will likely be getting brittle, could already have a leak. Just be easy. I had one that was still flexible at the MAP sensor, thought it was fine only to see it'd disintegrated on the other end from relatively minor movement.
The TBI kits typically cover the two sizes of TBI, as well as minor differences between Gen 1 and Gen 2 (for lack of a better term) TBI. Yes, take the TBI apart, replace the internal gasket, blow out the passages (especially the big vacuum port on the lower rear part of the body. The small rectangular "vacuum manifold" on the lower front of the TB must also be replaced. Mine appeared OK, but it was leaking somewhere because once re-done it ran beautifully. Before the repair it'd gotten so bad it literally sounded like an old 4 cylinder diesel tractor. A leak in those gaskets will throw the MAP outta whack too.
Haven't done a dash light repair, but it comes down to getting the proper bulb and pulling the dash panel out (oh joy).
I guess ill try and find a way to pull it off then lol

The gaskets i got in my kit look wayyy to thin to actually be serious. My gaskets on the tb right now are almost a 1/2 inch thick! The gaskets in the box are paperthin. Plus theres a bunch of grooves. I guess ill go buy some real ones lol

Btw sorry it took so long i live in illinois and was very close to the storms. Got a few scratches to show for it haha
 

·
Registered
Joined
·
2,037 Posts
How old are the injectors? I had a pair a few years ago that failed by just pouring gas. More recent replacements, one failed by shutting down, and the other was spraying a too-fat cone of fuel.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #10
How old are the injectors? I had a pair a few years ago that failed by just pouring gas. More recent replacements, one failed by shutting down, and the other was spraying a too-fat cone of fuel.
The injectors are brand new. Iv bought three pairs. I had my timing adjusted and that mechanic said they were bad. So i replaced them. Then my truck screwed al up and another mech said my injectors were bad. Along with my brain and some other things. So i replaced all of them but it hasn't panned out very well lol
I took the tb off and apart yesterday and when i put it back on i quickly wanted to see if it would start. So i plugged everything back in and turned the key to hear clicks! Battery is dead lol

But this time i didnt hear a lot of gas shooting out. I cant turn the key and look so i just listen and look to see if my valve's are wet.

The left was noticeably wet while the right seemed like some mist hit it. Im going to jump the truck right now.
 

·
Registered
Joined
·
2,037 Posts
So it will only start with throttle applied? Light or heavy throttle? Does it run steady when throttle is applied.? Depending on your anwers, it could just be an issue with the Idle Speed Control Actuator.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #13
So it will only start with throttle applied? Light or heavy throttle? Does it run steady when throttle is applied.? Depending on your anwers, it could just be an issue with the Idle Speed Control Actuator.
It will start without throttle but will die quickly. As soon as i take my foot off it will stumble and die. But if i hold my foot on the gas it will rev high without trouble. Once i take my foot off theres no stopping the the shut off. I cant bring it back no matter how hard i try lol

Is that the plastic piece that connects to the throttle plate?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #14
I should specify i do not give throttle when i start. Once its started i floor it. Once i pull my foot off even a little bit the engine dies.
 
1 - 14 of 14 Posts
Top