DODGE RAM FORUM banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys,
First timer here. I have an '06 hemi 4x4.

When i step on the gas from a stop it revs to about 2000 rpm and barely moves anywhere.

I guesse what it feels like is its starting out in 2nd or 3rd gear, but with lots of rpms.

feel free to ask more questions to diagnose the problem.

PLEASE HELP
 

·
Resident Technician
Joined
·
14,202 Posts
Sounds like it could be in limp-in mode. Start by checking fluid level and condition, then scan the PCM for codes.
 

·
Registered
Joined
·
60 Posts
Hey guys,
First timer here. I have an '06 hemi 4x4.

When i step on the gas from a stop it revs to about 2000 rpm and barely moves anywhere.

I guesse what it feels like is its starting out in 2nd or 3rd gear, but with lots of rpms.

feel free to ask more questions to diagnose the problem.

PLEASE HELP
Did you do anything to the truck before this started? There is a pressure relief switch on the drivers side of the tranny about half way back. It is designed to reduce line pressure once you are at cruising speed. It is supposed to help with fuel mileage. I pulled my trans. out to replace a cracked torque converter. When I re-assembled, I did not have the plug pushed all the way back on the switch and the truck would hardly pull itself up the drive. I was pissed! After I cooled off, I read the beginning of the trans. section in my service manual and it talked about this switch among other things. I went back out, pulled the plug off the switch and made sure I had pushed it on till it "clicked". That fixed it.
Check the wiring to this switch, and if all else fails, try replacing the switch.
 

·
Premium Member
Joined
·
32,782 Posts
It may not matter, but
When was the last time that the transmission was serviced ?
filter(s) changed etc.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #7 ·
Fluid level is good, dont smell burnt. The codes i got were PO700 P0158 AND P2098. ill check out this switch your talking about. And honestly i have no idea when the last time the tranny was serviced. I just bought the truck a couple months ago
 

·
Banned
Joined
·
3,844 Posts
Fluid level is good, dont smell burnt. The codes i got were PO700 P0158 AND P2098. ill check out this switch your talking about. And honestly i have no idea when the last time the tranny was serviced. I just bought the truck a couple months ago
Tis better to be pissed off than pissed on (unless you like that sort of thing...)
Your codes:
P0158* 2/2 02 Sens Shorted To Voltage - messed up O2 sensor
P2098 Post Catalyst Fuel Trim Sys Too Lean Bank2 - probably related to above
P0700* EATX Ctrller DTC Present - means there is a tranny code present

I am surprised there isn't another code for something specific in the trans. These are the only codes?
 

·
Registered
Joined
·
2,504 Posts
Yes, you should have a code for some kind of trans fault.

There is no "switch" on the trans, however the speed sensors are both on the driver's side (one at the back of the bellhousing, one at the very back of the main case). If the connectors were loose (or disconnected) that would give you ratio problems and cause limp-in, but usually in that limp-in mode it will launch in 1st gear (normally) and then shift directly to 4th. I suspect the speed sensors are NOT your problem, but feel free to check them if you want. While you're under the truck, check the main 23-way harness connector on the trans (also on the driver's side) to make sure it's properly seated and latched.

But you really need to get the trans fault code(s), to figure out where the problem lies. If you'll give me the code(s), I can give you some more detailed troubleshooting instructions.
 

·
Registered
Joined
·
37 Posts
Had the same kind of problems with mine. The great Google told me that I was in limp mode. Codes p0750 and p0882 are on mine. I posted a new thread looking for answers. Is yours stuck in limp all the time or intermittent? Mine is intermittent.
 
1 - 10 of 10 Posts
Top