DODGE RAM FORUM banner

1 - 20 of 29 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
On my 2018 6.4L (46K miles) having an issue with the tranny, she shifts real hard into 4th then when it does that it just stays in 4th. if you stop then take off it will shift from 1st to 4th and stay there and overheat the tranny, no downshift or anything until you stop shut it off then start up and go again and everything is fine. This has happened quite a few times over the last two weeks. i have an appt for recalls and such on the 7th will get them to look at this. I do have a code reader might see if there are any codes that come up but just wanted to see if anyone else has had this issue or not and what to check for.
 

·
Registered
Joined
·
114 Posts
Hi, had this same thing happen in February when I was coming home from Canada snowmobiling. The morning we lleft it was -20 f and I let the truck (2016 Power wagon 6.4 hemi) warm up until the remote start timed out, moved the truck to the hotel entrance and shut it off. I loaded all the luggage in and took off from and made 200 ft got the trans too hot warming locked in 4th with no up or down shifts , figured it was just too cold for it outside drove for about an hour down the road (knew there was a dealership in that town) trans temp never got any warmer on the dash readout. I stopped for fuel and when I restarted everything went back to normal so I drove the 12 hours home . I had an inspection scheduled for the next week at the dealer so I mentioned it to them and they did check everything and no DTC's stored so they were clueless as to why this happened and blew it off as a glitch in the computer, hasn't re occurred since.
 

·
Registered
Joined
·
244 Posts
redwagon - how many miles? There was a transmission recall of sorts, but did not apply to us, I think (Gen IV trans w/ HEMI). I have 2017 w/ 32.7k miles, no issues to date.
There is another post elsewhere with similar report.
 

·
Registered
Joined
·
114 Posts
redwagon - how many miles? There was a transmission recall of sorts, but did not apply to us, I think (Gen IV trans w/ HEMI). I have 2017 w/ 32.7k miles, no issues to date.
There is another post elsewhere with similar report.
It was around 32-33000 miles. Mine has had the selenoid recall done as well .
 

·
Registered
Joined
·
2,029 Posts
On my 2018 6.4L (46K miles) having an issue with the tranny, she shifts real hard into 4th then when it does that it just stays in 4th. if you stop then take off it will shift from 1st to 4th and stay there and overheat the tranny, no downshift or anything until you stop shut it off then start up and go again and everything is fine. This has happened quite a few times over the last two weeks. i have an appt for recalls and such on the 7th will get them to look at this. I do have a code reader might see if there are any codes that come up but just wanted to see if anyone else has had this issue or not and what to check for.
Hi, had this same thing happen in February when I was coming home from Canada snowmobiling. The morning we lleft it was -20 f and I let the truck (2016 Power wagon 6.4 hemi) warm up until the remote start timed out, moved the truck to the hotel entrance and shut it off. I loaded all the luggage in and took off from and made 200 ft got the trans too hot warming locked in 4th with no up or down shifts , figured it was just too cold for it outside drove for about an hour down the road (knew there was a dealership in that town) trans temp never got any warmer on the dash readout. I stopped for fuel and when I restarted everything went back to normal so I drove the 12 hours home . I had an inspection scheduled for the next week at the dealer so I mentioned it to them and they did check everything and no DTC's stored so they were clueless as to why this happened and blew it off as a glitch in the computer, hasn't re occurred since.
Hi @ArmyRXP & @redwagon - If you decide to follow up on this concern any further with your dealers, please be sure to follow up with us via private message. I would like to escalate cases on your behalf so that you and your dealers can be connected with a specialist who can work with you to exhaust all available resources in addressing this.

Mark
RamCares
 

·
Registered
Joined
·
244 Posts
Yeah, that's very unlikely to be oil-related. Not enough miles to oxidize enough oil to stick solenoid valves even if it ran hot. Talk to ramcares private message and ask a tech forum.
 

·
Registered
2016 Outdoorsman, 6.4 Hemi, 2.5 level, MBRP dual exhaust, 295/60/20 ProComp A/T
Joined
·
26 Posts
Mine did the same at 60k, had to change the solenoid again.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #8
Hi @ArmyRXP & @redwagon - If you decide to follow up on this concern any further with your dealers, please be sure to follow up with us via private message. I would like to escalate cases on your behalf so that you and your dealers can be connected with a specialist who can work with you to exhaust all available resources in addressing this.

Mark
RamCares

Mark,

Have an appointment o the 7th of May and will add this to the list and have them check it out. Will be going to Genes Chrysler Ram in Fairbanks AK.

Gary
 

·
Registered
Joined
·
244 Posts
I don't recall when the trans solenoid recall was for. I remember my truck wasn't included, so didn't worry about. I'm seeing other Gen IV trucks involved in this thread, so now I'm worried @ 33k miles. 2017 Ram 2500 with 6 speed auto trans behind 6.4l HEMI.
 

·
Registered
Joined
·
2,029 Posts
Mark,

Have an appointment o the 7th of May and will add this to the list and have them check it out. Will be going to Genes Chrysler Ram in Fairbanks AK.

Gary
Thank you for the follow up on this, Gary. If you wouldn't mind following up with me via private message to provide your VIN and contact info, I would be happy to get a case escalated for further support.

Mark
RamCares
 

·
Registered
Joined
·
190 Posts
Discussion Starter #11
Thank you for the follow up on this, Gary. If you wouldn't mind following up with me via private message to provide your VIN and contact info, I would be happy to get a case escalated for further support.

Mark
RamCares

PM Sent
 

·
Registered
Joined
·
3 Posts
Took my 2016 2500 6.4 to the dealer for this repair today. The service tech said it is part of the recall, but now I m not sure if he just said that and then will be charging me for it when I go to pick it up =.
 

·
Registered
Joined
·
3 Posts
Hello,
I have a 2010 1500 slt and have had nothing but trouble with this truck and dealer sucks here in old bridge nj, route 18 dodge in east brunswick nj $5000 for new and $4300 for rebuilt. wtf. The truck started the 4th gear limp so i changed the solenoid pack the one with the multi pin connector that pokes out from trans pan on top and that seemed to fix it for about six months then installed another and another exchange and install but now the truck just stays in first gear and no shift or starts in 4th gear then jerks down into 1st and feels like i'm going to drop a drive shaft... I am now ready to pull the trigger for a trans shop to give me an answer,If I didnt have a tuner I would be on my ass somewhere because I clear the codes and it get me around town but Ford/Chevy is my next truck. Just venting:)
 

·
Registered
Joined
·
3 Posts
Thank you for doing so, just had a chance to follow up!

Mark
RamCares
hi, i have had nothing but issues with past 2 trucks.... my 2016 ram 2500 6.4 tranny would buck like ridin a bull dealership could not find anything ha. so i traded it for my 2017 ram 2500 6.4 ( a week later dealership called me asking if i had a tuner on my16 cause tranny had issues ha told ya) no tuner by the way! anyway my 2017 has been acting up changing gears hard, not going into passenger gear, staying in 4th etc. then this am i get codes 735 and 729, 5&6 gear incorrect ratio wtf
 

·
Registered
Joined
·
3 Posts
hi, i have had nothing but issues with past 2 trucks.... my 2016 ram 2500 6.4 tranny would buck like ridin a bull dealership could not find anything ha. so i traded it for my 2017 ram 2500 6.4 ( a week later dealership called me asking if i had a tuner on my16 cause tranny had issues ha told ya) no tuner by the way! anyway my 2017 has been acting up changing gears hard, not going into passenger gear, staying in 4th etc. then this am i get codes 735 and 729, 5&6 gear incorrect ratio wtf
 
1 - 20 of 29 Posts
Top