DODGE RAM FORUM banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hello. I'm running into an issue with my 09 Ram Transmission. I was at a light, went to take off, and it put itself into gear selector mode and stays in 4th. Bogs bad when taking off because all I have now is 4th and reverse. It has thrown a code. P0750 which states "Shift solenoid A". I tried resetting the computer by unplugging the battery. It went away and I had full range of gears for about 2 minutes when it automatically went into 4th again. I have heard this may be a solenoid pack may fix this problem. Just want to consult with my fello ram members. See if anyone has run into this issue. Also now when I put it into park or neutral, there is this whining noise, sorta sounds like something may be slightly grinding? Please if anyone can help that would be great as the dealerships have told me they want to take the transmission apart to figure out the problem, which totals to over $1000. Not really in the mood to spend all that money to find problems. Thanks for the help in advance guys.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thank you very much for the help! I will read what is said and try a bit of diagnoses myself. I appreciate the helpful link.
 

·
Registered
Joined
·
10 Posts
HELLO..
I too have the P0750 issues,,been here an other sites trying to make sure I'll be fixing the right thing, (Solenoid)
My question ,,,is the Shift Solenoid AND the Governor Pressure Control Solenoid THE SAME THING,,!!?

I'm getting two different answers.


THANKS
 
1 - 6 of 6 Posts
Top