DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I have a 2005 ram 1500 4wd automatic with the 5.7 Hemi that sometimes will start others the starter will just click. I can get it to start by grounding it out from the battery when it decides not to start. I have replaced all of my ground and hot wires with with 2ga wire, I run a new optima yellow top, new alternator, and new starter. In the mornings it'll start just fine but when I get to work (30min drive) if I shut it off and try to re-start it it'll just click and it won't show what gear I'm in (has the little box around all gears) even after I get it started. Everything else looks/functions as it should. Could it be the trans range selector? But range selector was replaced about 5k ago could it have gone bad that fast?
 

·
Registered
Joined
·
34 Posts
Seems like I read something like that for the fourth gen trucks. Putting it in neutral and trying to start it would sometimes work. It might at least point you to what is broken if it is the trans selector
 

·
Premium Member
Joined
·
32,722 Posts
I had a vehicle that started just fine every time, Except when i drove it for about an hour or more continuously, then i would stop somewhere for some reason & that vehicle would have to be jumped to start.
It turned out that the battery that i had installed was too small in size for that vehicle
I bought the correct size battery & that problem cleared up
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks for the responses...I finally got around to hook a reader to it today and confirmed even tho CEL isn't on I am throwing a code for the range sensor. I said screw it and now have a new trans coming in hopefully be here in a day or two! Figured might as well since this one has 200k AND it was the wife's idea to just order a new one lol
 
1 - 4 of 4 Posts
Top