DODGE RAM FORUM banner

1 - 18 of 18 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
AJ here...I am new to the forum. I have a 2013 RAM 1500 5.7L Sport.

Just randomly the truck decided it did not want to start. I first noticed a problem with the key fob not unlocking or locking the truck. I replaced the batteries in that and also tried my other fobs. Same issue.

Once I get into the truck with the actual key and put the key in the ignition and turn it to ACC/RUN/START...nothing happens. I have interior lights, headlights, the power locks work, etc. I do not have anything on my screens except the mileage and that the door is open.

The truck would randomly come back to life but now it seems to be completely non compliant as it is currently stuck at my work.

I have put a new battery on, checked all of the fuses, checked all the possible harness' that it might be...I am out of options.

Thanks,
AJ
 

·
Registered
Joined
·
312 Posts
I recently had similar problems with my '14. It died on me a couple times and finally it would not start. I was not able to determine the issue. Changed the battery and still no start. I ended up having it towed to the dealer. I've had it back for about a week with no problems as of yet. This is what they found.




 

·
Registered
Joined
·
312 Posts
Thanks for the update. Glad to hear your truck is back on the road. Mine has been good since the trip to the dealership.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Have you had any issues with o2 sensors and the CEL light not being able to be turned off? I got the code p0038 for a bank 1 sensor 2 and I changed it but the light remains on and I cannot clear the code. This appeared after I got the RF Hub replaced.
 

·
Registered
Joined
·
312 Posts
I did get an O2 sensor(s) fault on Saturday the 18th after adding 5.5 gallons of high octane fuel to an 1/8 tank. A local performance shop was doing dyno pulls on a dynojet for $75. I was curious to the difference in numbers between it and the mustang dyno mine was on this spring. I ended up not doing it. It would have been about a two hour wait but I had fish to catch. I have since cleared the faults and haven't had any more issues since 93 octane is back in the system.
 

·
Super Moderator
Joined
·
34,750 Posts
What is "high octane" to you if you usually run 93?


JW
 

·
Super Moderator
Joined
·
34,750 Posts
Oh right you have the blower
 

·
Registered
Joined
·
312 Posts
I checked with the tuner first and he said a 50/50 mix would be fine with my tune. Don't know how much additional hp I would have gained but I do know how much additional dent in my wallet I gained!
 

·
Registered
Joined
·
144 Posts
It ended up being the RF Hub behind the back seat.



Mine has been doing the same. I have the keyless fob. To start the truck I have to touch the fob to the start button for it to see it. looks like I might have to change the RF hub is that what the issue was?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #13 ·
Rf hub

Mine has been doing the same. I have the keyless fob. To start the truck I have to touch the fob to the start button for it to see it. looks like I might have to change the RF hub is that what the issue was?
Yes it ended up being the RF Hub. It would have cost me $600 or so but I got a discount from a guy I know at the dealership so it cost me around $400. Ever since it was replaced it has been working fine.

You could probably replace it yourself but the dealer has to reprogram your key fobs. The hub is located behind the drivers side back seat. They had to remove the whole seat to get to it.

Hope this helps and goodluck!
 

·
Registered
Joined
·
144 Posts
Yes it ended up being the RF Hub. It would have cost me $600 or so but I got a discount from a guy I know at the dealership so it cost me around $400. Ever since it was replaced it has been working fine.

You could probably replace it yourself but the dealer has to reprogram your key fobs. The hub is located behind the drivers side back seat. They had to remove the whole seat to get to it.

Hope this helps and goodluck!



Another thread had a recall on the RF Hub for 2014's Mine is a 2013 and experiencing the same thing. I am going to have to call Dodge and see if they will cover it under the recall.


https://www.ramtrucks.com/webselfservice/pdf/P15.pdf
 

·
Registered
Joined
·
144 Posts
Dealer wants to do a scan on the system and charge me $50 when it's clearly the issue. There's no codes on the dash what would a scan pickup?
 

·
Super Moderator
Joined
·
34,750 Posts
If you want them to replace the RF hub that's the end of it, you pay the parts and labor for it to be replaced. You aren't asking them to diagnose anything and won't pay for a diagnosis.
 

·
Registered
Joined
·
144 Posts
If you want them to replace the RF hub that's the end of it, you pay the parts and labor for it to be replaced. You aren't asking them to diagnose anything and won't pay for a diagnosis.



Exactly. I won't pay them for a diagnostic fee when I know thats the problem. It's like asking them to do a brake inspection when I want the brakes changed lol
 
1 - 18 of 18 Posts
Top