DODGE RAM FORUM banner

1 - 10 of 10 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
My Uconnect in my limited just updated - and I clicked OK rather than 'whats new'. Does anyone know of a link to see the change log? or did someone take a pic of what the new features were? (I am guessing performance enhancements).

Many thanks.
 

·
Registered
Joined
·
7 Posts
Not sure about what was included however now mine won’t recall my settings. Have to tell it every single time what I want and where I want it.
Would also have loved to see the darn agreement go away after accepting it the first time.
No noticeable changes as of yet.
 

·
Registered
Joined
·
301 Posts
My Uconnect in my limited just updated - and I clicked OK rather than 'whats new'. Does anyone know of a link to see the change log? or did someone take a pic of what the new features were? (I am guessing performance enhancements).

Many thanks.
Just updated mine. Not issues yet. SiriusXM station presets retained.
Whole update takes around 30 min, and you can drive while it updates, but w/o nav, SOS, etc. until it completes.
 

·
Registered
Joined
·
44 Posts
I took a screenshot of the update message. Really nothing. It said for more details to follow the prompts. I did and it went down the road of calling assist. I spoke with them and they know nothing. The only change I’ve seen is part of your screen at the bottom has a next turn progress bar that eats up real estate. Just want that to go away. I have not had time to see if you can make it go away.
 

·
Registered
Joined
·
33 Posts
I've heard on another blog that guys are reporting the radio sound is better. Much louder and full bodied (whatever that means). Mine updated too and the only change I've noticed is my screen is blank every time I start the truck (completely black as if it's turned off). The radio comes on and plays but NO DISPLAY. I have to turn the radio OFF and back ON (some times multiple times) before the display comes back. I tried the "Screen On/Off" button but that doesn't do anything at all. Still LOVE the truck though!
 

·
Registered
Joined
·
151 Posts
The sound is substantially better, especially from SiriusXM. Occasional blanking of the screen seems to be resolved.
 

·
Registered
Joined
·
2,202 Posts
I've heard on another blog that guys are reporting the radio sound is better. Much louder and full bodied (whatever that means). Mine updated too and the only change I've noticed is my screen is blank every time I start the truck (completely black as if it's turned off). The radio comes on and plays but NO DISPLAY. I have to turn the radio OFF and back ON (some times multiple times) before the display comes back. I tried the "Screen On/Off" button but that doesn't do anything at all. Still LOVE the truck though!

Hi Buzzard69,
If you continue having these concerns, we would recommend reaching out to our Uconnect support team at 1-877-855-8400. They will be in the best position to troubleshoot with you. If you find you need any additional assistance, please feel free to send us a PM.
Julie
Ram Social Care Specialist
 

·
Registered
Joined
·
33 Posts
Thank you Julie. I will call them if I continue to have issues. I park in a garage where I lose the signal. I think it might have something to do with the back-up camera being on and the U-Connect system connecting to the satellite signal. I've noticed if I pause in my driveway for a minute of so, it doesn't seem I have an issue. If I just start the truck and back out, the radio comes on (music plays) but the entire display is blank (black). Turning it on/off sometimes works, sometimes not. Eventually after turning on/off a few times the display comes on. Thanks again for your response. Much appreciated.
 
1 - 10 of 10 Posts
Top