DODGE RAM FORUM banner

1 - 20 of 24 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
2nd time now. First time was some months back. Truck is not driven a whole bunch. Bought mid June 2018. First time it happened we turned it off and went in to shop for an hour. Came back out and it was fine. Just started it up and here it is again. Truck has about 4800 miles on it. Anyone else seen this or had to get it fixed?

130869
 

·
Registered
Joined
·
6 Posts
My 2018 ram has had uconnect issue for almost a year, the unit has been replaced once I get the blue screen of death, a black screen with nothing, ram will not replace it again, they say it a uconnect issue and uconnect says it's a software issue with no EED for the update to fix it
 

·
Registered
Joined
·
157 Posts
Lets see if "RAM CARES" jumps into this, doesn't matter if they don't have a fix, this is a major selling feature on these vehicles and they should fix it or replace the unit again and again. If they truly don't have a fix, let them make a couple of payments for your inconvenience. And if it been in three times Id be talking about buy back.
 

·
Registered
Joined
·
6 Posts
I was a step away from rebuy from RAM care when uconnect said the update would be out by DEC 31 2019, so now we are in FEB 2020 and uconnect has no EDD on when a fix will be available, and wont send it to rebuy and RAM care says they're is nothing they can do as it's a uconnect issue not a RAM issue, and no nothing on any compensation while I have a truck with a centerconsol that does not work
 

·
Registered
Joined
·
2,141 Posts
2nd time now. First time was some months back. Truck is not driven a whole bunch. Bought mid June 2018. First time it happened we turned it off and went in to shop for an hour. Came back out and it was fine. Just started it up and here it is again. Truck has about 4800 miles on it. Anyone else seen this or had to get it fixed?

View attachment 130869
My 2018 ram has had uconnect issue for almost a year, the unit has been replaced once I get the blue screen of death, a black screen with nothing, ram will not replace it again, they say it a uconnect issue and uconnect says it's a software issue with no EED for the update to fix it
Hi,

I'm sorry to see this is happening. If this occurs again, I would be happy to open a case for you and get you over to a Uconnect specialist. Please send us a message if this is something you would like to do.

Alison
RamCares
 

·
Registered
Joined
·
183 Posts
Discussion Starter #9
Heard from FCA saying there is a service bulletin out on this. I have an appt with local Chrysler dealership on Wednesday.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #10
OK, had service done today along with Oil Change. Service bulletin 08-003-19 stated an update of Radio software was needed. I am not so sure the Radio was an issue but will keep an eye on it since this was the second time. Is there anyway to actually see SB 08-003-19 myself.
 

·
Registered
Joined
·
1 Posts
Lets see if "RAM CARES" jumps into this, doesn't matter if they don't have a fix, this is a major selling feature on these vehicles and they should fix it or replace the unit again and again. If they truly don't have a fix, let them make a couple of payments for your inconvenience. And if it been in three times Id be talking about buy back.
Ram don't care want thousand to replace I'm looking at other trucks should have been recall 2014 2500
 

·
Registered
Joined
·
24 Posts
Check the connectors on the back of the unit. A loose connection can cause such issues. I had a unit that would switch from USB to radio by itself whenever it felt like it. After replacing the unit I did some exploratory surgery on the old one and found that a flat ribbon cable between the radio and the touch screen was broken and would make intermittent contact thus changing the input source.
 

·
Registered
Joined
·
32 Posts
Sorry to say FCA sold you the truck, get a lawyer, you will win. Be sure and keep all correspondence with anyone on this topic.
Had several problems with my 2018 Ram 1500 and FCA never resolved the issue. I resolved the issue by hiring “The Cremeens Law Group PLLC in Tampa, FL.” You pay nothing, FCA pays all legal cost and all they do is lemon law cases. However you must follow the process shown in your handbook that came with the vehicle and get everything in writing. Good Luck.
 

·
Registered
2020 Ram 3500 Laramie 4x4 Dually 6.7 Cummins HO
Joined
·
13 Posts
Check the connectors on the back of the unit. A loose connection can cause such issues. I had a unit that would switch from USB to radio by itself whenever it felt like it. After replacing the unit I did some exploratory surgery on the old one and found that a flat ribbon cable between the radio and the touch screen was broken and would make intermittent contact thus changing the input source.
Wow, this is exactly what my 2015 3500 Laramie was doing. It was like it was possessed. Took a video, dealership couldn't figure it out. They sent it to Chrysler engineers and they couldn't figure it out either so they replaced the entire head unit with touch screen and the entire stereo/backup camera wiring harness because the camera was acting up also. I must say I guess my dealership is a good one because the truck's warranty had not long run out from time but because of low mileage they did all of the work under warranty. To the original post, you just haven't found the right person yet. When you do they'll fix it...
 

·
Registered
Joined
·
3 Posts
2nd time now. First time was some months back. Truck is not driven a whole bunch. Bought mid June 2018. First time it happened we turned it off and went in to shop for an hour. Came back out and it was fine. Just started it up and here it is again. Truck has about 4800 miles on it. Anyone else seen this or had to get it fixed?

View attachment 130869
I have a 17 Ram that did this recently. Dodge has a fix for this problem now that all Ram dealers are now using. Hendrick Dodge Ram Jeep in Concord,NC did mine under warranty. I had to leave truck for the better part of the day but all is good since reprogram.
 

·
Registered
Joined
·
3 Posts
I couldn’t tell you about the service bulletin. Service advisor told me I was the first to have it done by them as they had just received it the day I bought the truck in for service. As others stated above there are other issues in play that could be going on.
 

·
Registered
Joined
·
15 Posts
I have a 2019 Ram Rebel($62K) with a 12" Uconnect system that has had on and off issues from the beginning... at first I did not recognize them as something was wrong with system because of the new system. When I figure enough is enough I contacted Uconnect and got a case manager Sherri , who walked me through a bunch of fixes that did not work, finally said you need a software update 08-009-19 REV. B "and this should fix all your issues"...
Made an appointment (1/17/2020) with local dealer who did the update and a few recalls, along with oil change, tire rotation , etc. Said everything was fixed and good to go.
On drive home which is almost a hour, the 12" NAV started to act up, rear camera would come on and would not go off for a long period of time than went off on its own. All the route numbers on Nav screen where all little black boxes.. Got home called dealer..... They said bring it back and we will reinstall the update and find the bad files and fix them... so drove a hour back, sat around in waiting room for a hour or so, Parts guy(Richard) comes out to get me hands me keys says we can not fix it and update did not work, I have ordered a new RADIO with no ETA.
Couple weeks later get a call or I call ( I forget) Uconnect say the are not replacing radio I need to go back to dealer for a new update.....I did this on Feb 3, 2020 (monday)..
I get a call Feb 4, 2020 saying they can't fix it and they are waiting for STAR ( who ever that is) to make a decision. Got a call Feb 6 from Uconnect case manager Laura ( who I have been calling all week , with no response,) since she and the dealer originally said they unit was bad and they were going to replace it, now saying they are not going to replace it and I need to wait for the next update that "should" be out in the next quarter and that "should" fix all the issues. Later that day Feb 6, dealer (Garry) calls with the same news. No ETA on new update but they need the loaner back and they want me to come and get the UNSAFE truck and drive it around until the new update is available.
Well the first 3 attempts did not work and actually cause other issues that the dealer says are not related like my sensors would go off on there own. While driving the front sensor would go off like I was ready to hit something and stay on till I pulled off road and turn truck off. The rear camera would pop up on screen while driving and could not get it off... than on its own would go off . many other things I will not bore you with.. dealer said there was a new sensor update they did on this Feb 3rd trip said should fix those problems ( not sure why they did not do it on first failed update attempts).
I am done fooling with RAM, Uconnect, STAR (who ever they are) anylonger and will be contacting a lawyer on Monday to pursue a Lemon Law case and a buyback... Now I need to go and pick up this $62 K piece of crap and see what they screwed up on this failed update ... VERY FRUSTRATED with RAM and there lack of customer services... going back to FORD
 

·
Registered
Joined
·
2,141 Posts
I have a 2019 Ram Rebel($62K) with a 12" Uconnect system that has had on and off issues from the beginning... at first I did not recognize them as something was wrong with system because of the new system. When I figure enough is enough I contacted Uconnect and got a case manager Sherri , who walked me through a bunch of fixes that did not work, finally said you need a software update 08-009-19 REV. B "and this should fix all your issues"...
Made an appointment (1/17/2020) with local dealer who did the update and a few recalls, along with oil change, tire rotation , etc. Said everything was fixed and good to go.
On drive home which is almost a hour, the 12" NAV started to act up, rear camera would come on and would not go off for a long period of time than went off on its own. All the route numbers on Nav screen where all little black boxes.. Got home called dealer..... They said bring it back and we will reinstall the update and find the bad files and fix them... so drove a hour back, sat around in waiting room for a hour or so, Parts guy(Richard) comes out to get me hands me keys says we can not fix it and update did not work, I have ordered a new RADIO with no ETA.
Couple weeks later get a call or I call ( I forget) Uconnect say the are not replacing radio I need to go back to dealer for a new update.....I did this on Feb 3, 2020 (monday)..
I get a call Feb 4, 2020 saying they can't fix it and they are waiting for STAR ( who ever that is) to make a decision. Got a call Feb 6 from Uconnect case manager Laura ( who I have been calling all week , with no response,) since she and the dealer originally said they unit was bad and they were going to replace it, now saying they are not going to replace it and I need to wait for the next update that "should" be out in the next quarter and that "should" fix all the issues. Later that day Feb 6, dealer (Garry) calls with the same news. No ETA on new update but they need the loaner back and they want me to come and get the UNSAFE truck and drive it around until the new update is available.
Well the first 3 attempts did not work and actually cause other issues that the dealer says are not related like my sensors would go off on there own. While driving the front sensor would go off like I was ready to hit something and stay on till I pulled off road and turn truck off. The rear camera would pop up on screen while driving and could not get it off... than on its own would go off . many other things I will not bore you with.. dealer said there was a new sensor update they did on this Feb 3rd trip said should fix those problems ( not sure why they did not do it on first failed update attempts).
I am done fooling with RAM, Uconnect, STAR (who ever they are) anylonger and will be contacting a lawyer on Monday to pursue a Lemon Law case and a buyback... Now I need to go and pick up this $62 K piece of crap and see what they screwed up on this failed update ... VERY FRUSTRATED with RAM and there lack of customer services... going back to FORD
This certainly sounds like a frustrating situation, LarryR1051. From your message, the proper internal teams have been made aware of your concern and working diligently to resolve your concerns. If you have any questions or concerns, we do recommend reaching out to your owning agent.

Kate
RamCares
 

·
Registered
Joined
·
15 Posts
This certainly sounds like a frustrating situation, LarryR1051. From your message, the proper internal teams have been made aware of your concern and working diligently to resolve your concerns. If you have any questions or concerns, we do recommend reaching out to your owning agent.

Kate
RamCares
Kate more than frustration. Now the dealer ( Gary) in service will not provide me with paperwork that there service department worked on my truck a second time for a complete new issue with the Nav unit because it was on the same day.

First time I paid my bill, that should have closed out my ticket. A couple hours later I had different issues I called dealer and was told by Richard ( service manager) he would set up another appointment to try and fix the problem, I ask if they had time that day, he check and said yes. I got back in my truck and drove a hour back to dealer, they worked about a hour and like above Richard came into waiting room handed my keys and said he ordered a new radio which now seems no one has a record of. I asked for the paperwork on my SECOND visit and wanted documentation on what they did and that they had tried and failed again.... when I came to pick up my truck the 3rd time

Gary said he had found Richard's paperwork on the phone, cause I had him find it and have it before I went down and wasted more time. When I went down they handed me what I already had which was the first failed attempt and said there was no other paperwork, Richard did something for a hour that did not fix the problem and I wanted documentation which they will not supply.

PLUS the paperwork today did not have ANYTHING on what they did that STAR sent me there to have done on the Uconnect system, Gary said they did not do anything.. REALLY that was the reason I had to return... and Gary would not let me speak to a manager until another service guy went on his own and got the Parts manager after me waiting 30 minutes standing at counter. Just piss poor services ( Richard the service manger was out recovering from surgery will be back next week) I did talk to Clark the Parts manager who was a super nice guy and said YES they did work on it again and he said he did not know why it was not included on the paperwork, but he said to wait in his office and he would get it done.... The second failed attemp with Richard he had to look into cause there was no record of me coming back a second time... I said ask Richard and the Tech who worked on it.... I am waiting now, Clark said he would get back to me.. The Dealer is Fred Frederick, Easton Maryland
 
1 - 20 of 24 Posts
Top