DODGE RAM FORUM banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I cannot seem to pair a Verizon Motorola Razr to my '09 1500 with the uconnect because the uconnect doesn't give commands audibly. I have tried to pair the device without the audio but it is hard to clarify the pin and the phone rating. Has anybody had any issues with their audio in setup>pair a device with uconnect? - The radio is not navigation supported but is Sirius capable.

Also, has anyone had an issue with their rear window seal? Water leaked down the back seat on the passenger side of the truck - I put some Butyl adhesive underneath the weather stripping because I though that is where it was running down into the cab. It turns out that it still leaks. I was just wondering if it is a common occurrence!

Anyone have a belt squeal on startup of the 5.7L? I had the powersteering pump replaced (+ line in and line out) because they thought it was the issue. It's squealed a few times since then but only cold starts, exacerbated by moisture.

I'd like to get this truck into the dealer before 36k miles but I just rolled 34k and don't know if I'll make it, either way it would be nice to get these things ironed out.

PS. Anybody purchase the max care plan or lifetime plan and want to wager in on the conversation about pro's and con's?

Thanks forumz
 

·
Some Assembly Required
Joined
·
7,205 Posts
The rear window is actually the 3rd brake light (high mount) leaking. Your dealer will fix under warranty. Common problem with the 4th gens.

Serpentine belt sounds like exactly that. and the Uconnect I cant help you with because I dont have it. LOL.
 

·
Registered
Joined
·
801 Posts
On the Uconnect system, have you used it in the past with a different phone?



I cannot seem to pair a Verizon Motorola Razr to my '09 1500 with the uconnect because the uconnect doesn't give commands audibly. I have tried to pair the device without the audio but it is hard to clarify the pin and the phone rating. Has anybody had any issues with their audio in setup>pair a device with uconnect? - The radio is not navigation supported but is Sirius capable.

Also, has anyone had an issue with their rear window seal? Water leaked down the back seat on the passenger side of the truck - I put some Butyl adhesive underneath the weather stripping because I though that is where it was running down into the cab. It turns out that it still leaks. I was just wondering if it is a common occurrence!

Anyone have a belt squeal on startup of the 5.7L? I had the powersteering pump replaced (+ line in and line out) because they thought it was the issue. It's squealed a few times since then but only cold starts, exacerbated by moisture.

I'd like to get this truck into the dealer before 36k miles but I just rolled 34k and don't know if I'll make it, either way it would be nice to get these things ironed out.

PS. Anybody purchase the max care plan or lifetime plan and want to wager in on the conversation about pro's and con's?

Thanks forumz
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
I got the truck in September (used, it is a 2009) and have not tried to pair any phone except for this Razr. - Thanks for the help!
 

·
Registered
Joined
·
801 Posts
Are the Uconnect buttons on the radio are on a small touch pad. If on a pad, can you post a picture of it?


I got the truck in September (used, it is a 2009) and have not tried to pair any phone except for this Razr. - Thanks for the help!
 
1 - 6 of 6 Posts
Top