DODGE RAM FORUM banner

1 - 4 of 4 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
I replied in another thread a couple of times - and just now found this particular area to post:

I bought my truck back at the end of May of this year. Came with the uConnect 5.0.

Pairing with my iPhone hasn't been an issue (though the voice commands through the head unit are a joke). But - over the last month or so, I have run into some playback issues using either a USB thumb drive or the bluetooth link with my iPhone. The radio will just hang, mid-song. Sometimes it shows that the media is still playing, but no sound comes out, or the screen just would freeze up.

Also - up until a couple of weeks ago - I didn't need to re-pair my iPhone to use it - but about every other time in the last week, I've had to pair them again.

Then along comes Wednesday afternoon - when I found the page to input your last 6 digits of your VIN to see if there is a software update for your uConnect unit. Indeed, it showed there is - I downloaded, got it on a clean/freshly formatted thumb drive, and off it goes:



After about 30 minutes, screen goes blank. Another 20 minutes and this:


I pulled the thumb drive - and the screen goes to this:


Put the thumb drive back in and the whole process begins over again.

Well - I gave up after the 5th or 6th attempt. Went to a dealership yesterday morning. They thought they could fix it right quick... an hour later, he comes in to say they ordered me a new radio - the tech tried a few times to update the software - all failing (duh!). So - I'm without backup camera, and front/rear park assist...

Also - for part of the day yesterday, the EVIC was stuck with this:


The "uConnect" screen I posted above is now on all the time when the ignition is on. The screen did go off for a couple of seconds while I was driving yesterday, but came right back on to the same logo.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #2
An update:

My radio was replaced last week. Took about an hour and a half (service dept. got confused... no clue what the deal was).

Positives: Radio now works, XM/Sirrus Service was changed over the day they ordered the new radio (I got an email with the info less than an hour after they actually placed the order that included the new radio's ID#).

Negative: Now neither of my thumb drives with nothing but music on them are recognized or will play correctly... sigh...
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
An update:

My radio was replaced last week. Took about an hour and a half (service dept. got confused... no clue what the deal was).

Positives: Radio now works, XM/Sirrus Service was changed over the day they ordered the new radio (I got an email with the info less than an hour after they actually placed the order that included the new radio's ID#).

Negative: Now neither of my thumb drives with nothing but music on them are recognized or will play correctly... sigh... So - any suggestions, or should I just revisit dealership with the new issue?
 

·
Premium Member
Joined
·
32,675 Posts
Reformat your thumb drive to work with FAT32
no other format will work

some ppl are using 32 Gig cards, others use 64 Gig cards & they also seem to work
 
1 - 4 of 4 Posts
Top