DODGE RAM FORUM banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Help. I did a really dumb thing - left my driver's side window down for about 2 days in the rain. Truck was parked in the driveway, and a neighbor pointed it out.

Now my dashboard warning lights are lit up like a Christmas tree. ABS / Brake / Airbag lights all on. Speedometer is dead, Odometer is frozen (nice perk). On the heater and A/C controls, the only functioning dial is the blower motor - all other dials and buttons are dead.

Everything else works fine, and the truck is driveable. I've tried to look for obvious disconnected or water-logged wires, etc, and don't seem to have any blown fuses. An internet search of this problem suggested a bad rear speed sensor, which I replaced, but to no avail. I've also had the battery disconnected a couple of times to try to reset, but no luck. Tomorrow I'll stop at the auto parts store to see if they can read any codes that might help.

Any help in diagnosing this issue would be greatly appreciated.
'03 1500 Quadcab 4wd 4.7
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
Had the warning code for the engine light read at O'Reilly Auto Parts and it only indicated the rear speed sensor. They cleared it and the engine light is gone, but no help on the others.
Any suggestions?
 

·
Registered
Joined
·
3 Posts
i read on the net about a Ram that the Speedo ,drivers window,and blower motor didnt work. There were a couple of dash lights on and everything else worked. What they found was a black wire that pulled out of the wire harness in the steering column. Its probably not it because yours happened after it probably got wet, but maybe it arched out because it got wet.
I have the same situation as you except my blower motor works. i read the wires are to short in the columnso when you tilt the steering wheel they sometimes pull out
 
1 - 3 of 3 Posts
Top