DODGE RAM FORUM banner

1 - 20 of 27 Posts

·
Registered
Joined
·
2,885 Posts
Discussion Starter #1
Ever since about 6 months after I got my truck it does this weird thing at WOT going from like 2nd to 3rd gear. It won't always do it though. But it'll get up all the way to 5200 rpms and then hesitates to shift into the next gear for like 3 or 4 seconds and while it's hesitating the engine just keeps hitting the rev limiter and it sounds really odd. I'm not getting any codes or any other shifting problems, just WOT from 2nd to 3rd. I try not to run it at WOT anymore just because it's a little embarrassing driving around and my damn truck doesn't wanna shift. Any help is greatly appreciated.
 

·
Premium Member
Joined
·
32,597 Posts
you have 2 choices
manually shift through the gears starting in 2nd gear
or put it in Tow Haul mode
try both methods
otherwise get a tuner
 

·
Registered
Joined
·
2,885 Posts
Discussion Starter #4
you have 2 choices
manually shift through the gears starting in 2nd gear
or put it in Tow Haul mode
try both methods
otherwise get a tuner
It still does it with the O/D off, and I can only go 1, 2, and then drive. I have the column shifter. And there are no tuners to change shift points on the 5.9
 

·
Registered
Joined
·
2 Posts
my '99 5.2 sport does the same thing, clean shift from 1-2 but 2-3 hits rev limiter and then shifts into low rpms to 3rd gear
 

·
Registered
Joined
·
2,885 Posts
Discussion Starter #7
my '99 5.2 sport does the same thing, clean shift from 1-2 but 2-3 hits rev limiter and then shifts into low rpms to 3rd gear
I don't really understand it. I did a bunch of runs here just a minute ago after work, and I couldn't get it to do it. Oh well
 

·
Registered
Joined
·
795 Posts
I don't really understand it. I did a bunch of runs here just a minute ago after work, and I couldn't get it to do it. Oh well
JC its happened to me a few times too:i_rolleyes:. I can still hear it in my head "vrrrrunnn vrrrrunnn vrrrrunnn vrrrrunnn vrrrrunnn" kinda makes you wanna ease of the pedal. Have you tried adjusting your kick down cable? I experimented with mine a little and its been fine about 3 weeks now. I'm not 100% sure that'll fix it. Now on my ram I had it adjusted to hold my gears longer with a hard shift. I'm assuming when its reaching for 3rd gear it couldn't reach past the rev limiter to grab it :4-dontknow: so I tweaked the kick down to shift a bit sooner hehehe I'm just guesstimating and troubleshooting over here:thk: since I wasn't able to find an answer I took the matter into my own hands, it seems to be working so far. Oh well time will tell.
 

·
Registered
Joined
·
2,885 Posts
Discussion Starter #9
JC its happened to me a few times too:i_rolleyes:. I can still hear it in my head "vrrrrunnn vrrrrunnn vrrrrunnn vrrrrunnn vrrrrunnn" kinda makes you wanna ease of the pedal. Have you tried adjusting your kick down cable? I experimented with mine a little and its been fine about 3 weeks now. I'm not 100% sure that'll fix it. Now on my ram I had it adjusted to hold my gears longer with a hard shift. I'm assuming when its reaching for 3rd gear it couldn't reach past the rev limiter to grab it :4-dontknow: so I tweaked the kick down to shift a bit sooner hehehe I'm just guesstimating and troubleshooting over here:thk: since I wasn't able to find an answer I took the matter into my own hands, it seems to be working so far. Oh well time will tell.
Ahhhh....Just seeing how you spelled it out like that reminds me of how it does that. Sends chills down my spine lol. I'm not sure what the kick down cable is?.. :4-dontknow:
 

·
Registered
Joined
·
795 Posts

·
Registered
Joined
·
795 Posts
Thanks man. I'm gonna have to fiddle around with that
No problem, just remember adjust in 1/8th increments make sure you mark the stock position with whiteout or marker that way you can use as a reference point.
 

·
Registered
Joined
·
795 Posts
:smiley_thumbs_up: wooh hoo:smiley_thumbs_up: no problem JC.
 

·
Registered
Joined
·
115 Posts
My truck does the same exact thing some times it'll even do it 1 to 2. I also adjusted the tv cable for a later firmer shift so maybe i'll try the same thing and see how it works for me too.
 

·
Registered
Joined
·
60 Posts
Sadly to say, mine also does the same thing occasionally at WOT and it is quite unnerving and embarrassing so I unfortunately don't do WOT acceleration much. I have no ideas about this but keep us posted what you find so I can attempt to fix this annoying problem!
 

·
Registered
Joined
·
2,885 Posts
Discussion Starter #17
Sadly to say, mine also does the same thing occasionally at WOT and it is quite unnerving and embarrassing so I unfortunately don't do WOT acceleration much. I have no ideas about this but keep us posted what you find so I can attempt to fix this annoying problem!
It's so weird to see so many people have this problem. I havent had a chance to toy around with it yet.
 

·
Registered
Joined
·
795 Posts
I havent had that problem since i last posted. I really do think the adjustment helped. JC dont be afraid to pop the hood! hehehe just kidding bud!
 

·
Registered
Joined
·
15 Posts
I had a 98 that did the same thing. Only had less than 30k miles. I changed the tranny fluid and filter just because it was routine maintenance I knew the dealership would charge me for doing if it had not been done yet (still under warranty). That fixed the problem. Never had any more prob. after that.
 
1 - 20 of 27 Posts
Top