DODGE RAM FORUM banner
1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Sorry I know theirs 100's of threads out there,but couldn't find a true solution.
So here it is I bought a 96 2500 4x4 with 120000 , seller stated it ran good but was hung up in first gear (I paid 600. for it) knowing I would need to drop a tranny in it . A friend of mine told me that a good trans flush with new filter plus replacing the Gov pres solenoid and sensor could take care of the problem, well hoping for a cheap fix , did it; well got it shifting but it takes 4000 rpm and bump of pedal to shift it into second when in second to much accel will kick it down to first if I manual shift it , seems like there's no second up shift or down shift , now once in third shifts fine , theirs no noise from trans strong reverse, shift 3-4 and od no problem just second seems to be giving me a problem , I have a trans lined up , but if there is something im missing that could correct this one then I can stick a grand into something else.
any input would be appreciated.

Also, no I have not had the trans scanned only scan done was a obdII eng scan which showed o2 sensor, and yes I used AFT+4 for fluid
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
Thanks for the reply Ramvan , I did some research today in some manuals and what I read matches pretty much your thought, so I have a used tranny I picked up for 300 I think ill through that in so I can use it , while I rebuild the one in there , any suggestions on beefing it up ? I was thinking more clutch pads, maybe HV pump, this truck is a puller and plower like to beef it up if I can.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 · (Edited)
Great info , thanks a bunch, can I buy a rebuild kit or do I have to by it by individual pieces? would you recommend a low stall or high stall torque converter? one last thing I heard that the inline check valves have become a problem would you suggest I remove them?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #8 ·
Well Ramvan thanks so much for all the info , I will be pulling this transmission this week-end to through in the used one, I am going to order the kit today , probably take me a week or so to do the rebuild as I never taken one apart. I do have tech manual and CD to view so I will take my time , I assume that if I was able to rebuild turbine engines while was in the Navy im pretty sure I can handle this lol. ill keep you updated with the progress and results.Thanks again for your inputs.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #10 ·
Well Ramvan I told you i would keep you updated, have the bad trans out and installed the used one , now drives fine. my kit is ordered should be here Mon or Tue , I started to disassemble it and low behold the kick down band is bad. when I took the valve body off found a thin piece of metal, I assume it was the kick down band anchor.their was some sludge build up in the valve body. hope to start rebuild next week. Is their anything else I should pay attention too as for as hardware is concerned.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top