DODGE RAM FORUM banner

What are the chances!?

2655 Views 25 Replies 7 Participants Last post by  BrandonB
So a few months back I was using my spotlight powered by the center console outlet. The light and the power to the plug-in gave out.
I checked the fuses myself and all were good. So a few weeks ago I brought it to the dealer. They said," fuses were good but we are going to have to trace wires to find the problem" so I booked an appointment.
Appointment was Tuesday past and yesterday they called and said that they fixed the plug. Apparently the fuse was missing..??
Anyways he also said I have a new problem. The truck is in the garage and won't come out of park.
They ordered some kind of shift bracket for the truck and that didn't fix it so he said he's going to have to check the wires and it may be also be an ecu probelm.
I didn't think the ecu had anything to do with a transmission. But anyways that's a pretty random problem that I'm having a hard time believing.
Any comments or similar coincidences?
1 - 1 of 26 Posts
I told them about what you said and he's going to check it out.
Also now there is only one headlight and one taillight working.
Something is going wrong somewhere.

Anybody else with any feedback on this?

ouch man, sounds like a whole **it ton of nasty wiring problems..
id get pissed off an demand to get a new truck lol (truck wasent messed up before i brought it here, hence why i refuse to take it back because they caused so many problems)
1 - 1 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top