DODGE RAM FORUM banner
7501 - 7520 of 7548 Posts

·
Registered
Joined
·
62 Posts
Been a while since I've checked in. Busy and expensive couple of weeks with the truck. Night before the 4th of July, went on a beer run and the truck started knocking and misfiring bad. Limped it home (with the beer, at least). Suspected a bad lifter, so replaced all of them and all the rocker arms, and as I was buttoning up the drivers side, I noticed one of the chain tensioners was actually broken. Dropped it off at my local shop since I really didn't feel comfortable dealing with pulling the front of the engine apart to do a timing chain kit, only to find coolant and fine metal shavings in the oil. Being that this was the original motor with almost 400k miles on it, I opted to drop in a reman long block. The old lump served me and my family well, certainly can't complain. Got it back today, flashed the 91 performance tune with the Flashpaq I bought right before the engine failure, and boy does she go now. With the transmission I put in 50k ago and all the other work I've done to it, aside from cosmetics I've basically got the closest thing to a brand new 04 I'll ever get...lol. Not my best financial move but this truck has a lot of sentimental value to me and my family. Stoked to have it back after 3 weeks and running better than ever.



 

·
Registered
14 Ram Express
Joined
·
261 Posts
Been a while since I've checked in. Busy and expensive couple of weeks with the truck. Night before the 4th of July, went on a beer run and the truck started knocking and misfiring bad. Limped it home (with the beer, at least). Suspected a bad lifter, so replaced all of them and all the rocker arms, and as I was buttoning up the drivers side, I noticed one of the chain tensioners was actually broken. Dropped it off at my local shop since I really didn't feel comfortable dealing with pulling the front of the engine apart to do a timing chain kit, only to find coolant and fine metal shavings in the oil. Being that this was the original motor with almost 400k miles on it, I opted to drop in a reman long block. The old lump served me and my family well, certainly can't complain. Got it back today, flashed the 91 performance tune with the Flashpaq I bought right before the engine failure, and boy does she go now. With the transmission I put in 50k ago and all the other work I've done to it, aside from cosmetics I've basically got the closest thing to a brand new 04 I'll ever get...lol. Not my best financial move but this truck has a lot of sentimental value to me and my family. Stoked to have it back after 3 weeks and running better than ever.



What did they bang you for the new motor? I probably would've gone the same route w the way truck prices are right now...

Sent from my SM-G988U1 using Tapatalk
 

·
Registered
Joined
·
62 Posts
What did they bang you for the new motor? I probably would've gone the same route w the way truck prices are right now...

Sent from my SM-G988U1 using Tapatalk
$7500 which included the Jasper long block, installation kit, various sensors, new motor mounts, and labor. Thought about just picking up another truck but comparable trucks are going for the same amount of money right now anyway. Bit the bullet, now I have what is basically a new '04 Ram lol. No regrets here.
 

·
Registered
2021 ram 1500 warlock,5.7l ,4x4
Joined
·
116 Posts
I just put 1k miles on my 2021 just purchased July 10th with 10 miles on her😀
 

·
Registered
14 Ram Express
Joined
·
261 Posts
It's only there when driving so probably not. Would be better if the outlet was on passenger side not driver side
Could tap it off the mirror or pull the head unit out and run the wire straight down and left over to the outlet.

Sent from my SM-G988U1 using Tapatalk
 

·
Registered
2021 ram 1500 warlock,5.7l ,4x4
Joined
·
116 Posts
Could tap it off the mirror or pull the head unit out and run the wire straight down and left over to the outlet.

Sent from my SM-G988U1 using Tapatalk
Thanks I may look into that. I'm use to using a blend mount. This mirror won't work with that kind if mount so had to make something up. Using different mounts. It gets the job done
 

·
Registered
14 Ram Express
Joined
·
261 Posts
Thanks I may look into that. I'm use to using a blend mount. This mirror won't work with that kind if mount so had to make something up. Using different mounts. It gets the job done
What mirror do u have? The one w the giant camera block for the auto highbeams?

Sent from my SM-G988U1 using Tapatalk
 

·
Registered
2021 ram 1500 warlock,5.7l ,4x4
Joined
·
116 Posts
What mirror do u have? The one w the giant camera block for the auto highbeams?

Sent from my SM-G988U1 using Tapatalk
No I do not have that one. The stem is less than than 1 inch. It has the assist and sos buttons. Not auto dimming for highbeams. I took a picture of it and sent it blend mount and they said they do not make a solution for it.
 

·
Registered
14 Ram Express
Joined
·
261 Posts
No I do not have that one. The stem is less than than 1 inch. It has the assist and sos buttons. Not auto dimming for highbeams. I took a picture of it and sent it blend mount and they said they do not make a solution for it.
Well, good news. I have the same damn mirror. Bought the mount and mirror wire taps bundle off of Amazon...

Sent from my SM-G988U1 using Tapatalk
 

·
Registered
14 Ram Express
Joined
·
261 Posts
7501 - 7520 of 7548 Posts
Top