DODGE RAM FORUM banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi , I have an 02 dodge ram 1500 quad cab. My windshield wipers will not come on when i turn the knob and the wiper fluid will not come out either also the turn signals on the dash do light up and click however the turn signal lights on the outside do not come on in the front or the rear , also the brights will not come on when i try to turn them on the indicator just shows up for a second and goes right back off, i tried holding it to see if the brights even came on and they do not , also the on off switch for the light appears not to be working either it will not turn the lights on or off but when i start the truck up the lights come on by themselves even with the knob turned off and they never came on by themselves before but they do go back off again when i turn the truck off, also on the heads up display where the compass and outside temp are displayed its not showing them temp any more just two dashes.

I was wondering if anyone might have any clue as to what may be causing this it just started happening a few days ago i replaced the battery today to see if that might help but it didn't I'm wondering if it might be the multifunction switch but i dont know if that would have anything to do with the headlight switch as well as the outside temp display.

I would be grateful for any insight anyone could provide thank you.
 

·
Registered
Joined
·
1,695 Posts
I'd agree with that and I also suspect it could be the mult-function switch except for the fact that the light switch isn't working.
 

·
Registered
Joined
·
2 Posts
Same Issue

I'm having the exact same issue with my 2002 4.7 Quad Cab. I thought it may be a blown relay, because it looks like "wiper high low" are all on the same connection. Bought a new relay and it didn't make a difference. I'm hoping it's nothing too expensive because I've put in a rebuilt engine, bearing and brake lines, all within the last 1,500 miles. Maintenance and repairs are part of the game, but the budget was long ago depleted. Any additional thoughts on this? I've had the issue since getting it back from the shop after the bearing and brakes were worked on. Thanks!
 

·
Registered
Joined
·
3 Posts
same issues

I have a 2007. 67l 3500 diesel with exact same problems. No turn signals, hazards, wipers and Also my low fuel indicator is not working. I changed multi function switch, tried a new TIPM.
Still nothing
 

·
Registered
Joined
·
1 Posts
I had all the same issues w/ 02 4.7 Quad cab. Noticed instrument cluster was illuminated, so I disconnected the + batt cable overnight so as not to drain the batt. I was planning to have work done for these issues the next day. Upon + batt cable reconnect the next morning all symptoms were gone. Full wiper control, full turn and brake signals, full flasher, interior lights, hi\low beams, information panel, tach, speedometer, door locks and remote control. Idk if there was something I missed but all systems seemed to work and are still working with about 15 minutes run time.
Does anybody have a similar story and resolution.
 

·
Registered
Joined
·
7 Posts
Truck runs but no safety accessories turn signal,wipers,brake light etc

I just went through this nightmare, no brake lights no turn signals, no horn, no wipers, no wiper fluid, no hazards, no running lights, no display on temp or mile per gallon economy etc, I found a used Fuse Box next to battery, carefully removed and replaced , back in business, except my running lights on back of truck and trailer are out, I've driving with hazards flashing at night, I may run a hot wire with switch or buy another fuse box, there are videos on you tube showing how to try and fix fuse box also , bad design moisture gets in and corrodes
 

·
Registered
Joined
·
6 Posts
Good day fellow Rammers, have anyone found a solution to this issue yet; indicators not functioning horn not working, headlights not switching between high and low beam, info screen not functioning? I changed out the TIPM and multi-function switch already. I want to replace the clock spring but I am not convinced it will resolve as the multi function switch is independent from it.
 

·
Registered
Joined
·
1 Posts
Hi , I have an 02 dodge ram 1500 quad cab. My windshield wipers will not come on when i turn the knob and the wiper fluid will not come out either also the turn signals on the dash do light up and click however the turn signal lights on the outside do not come on in the front or the rear , also the brights will not come on when i try to turn them on the indicator just shows up for a second and goes right back off, i tried holding it to see if the brights even came on and they do not , also the on off switch for the light appears not to be working either it will not turn the lights on or off but when i start the truck up the lights come on by themselves even with the knob turned off and they never came on by themselves before but they do go back off again when i turn the truck off, also on the heads up display where the compass and outside temp are displayed its not showing them temp any more just two dashes.

I was wondering if anyone might have any clue as to what may be causing this it just started happening a few days ago i replaced the battery today to see if that might help but it didn't I'm wondering if it might be the multifunction switch but i dont know if that would have anything to do with the headlight switch as well as the outside temp display.

I would be grateful for any insight anyone could provide thank you.
Did you figure it out? having the same on my 200 ram right now r and r the whole signal that didnt work Thanks
 

·
Registered
Joined
·
1 Posts
Just wanted to put on here that I have a 2008 Dodge Ram 1500 Quad cab. I had the electrical issue of no wipers, no function in the headlight switch, no warning lights coming on, no hazard lights and all fuses perfectly fine. The solution ended up being the dash cluster because the body control module is in the cluster. If anyone has this issue or close to it then check to see if you have a model that has a bcm integrated into it. The dealer would know. I ended up being able to pick one up from a junk yard for $40. I was trying to wire up a keyless entry system and ended up frying it.
 
1 - 10 of 10 Posts
Top